17732, "lydia-duncan", "[Library Stabilization] Should we rename BigInteger's 'bigint.remove()' method?", "2021-05-13T20:42:11Z"
This method name does not really seem clear to me. The function removes all instances of the factor (
f) arg from the other arg (
a), storing the result in
this and returning the number of times the factor was removed. I think "remove" conflicts pretty regularly with other remove methods. Maybe
bigint.removeFac() would be better? I'm open to other suggestions as well
This function is defined here: Number Theoretic Functions (GNU MP 6.2.1)