18011, "bradcray", "Should / could 'c_void_ptr' be replaced with 'c_ptr(void)'", "2021-07-01T00:48:14Z"
While reviewing the
CPtr module from a language stabilization perspective, it was noted that we could probably replace
c_ptr(void) to unify the two flavors of pointers into one. This issue asks whether anyone would object to doing so (assuming no show-stoppers present themselves in attempting it).
We believe that we got into the current state by virtue of initially supporting a type alias representing
void* as a distinct concept prior to any support for the generic
c_ptr(void). It also seems likely that we hadn't really solidified our
nothing features yet at the time we were introducing
Note that this issue interacts slightly with #18010.