New Issue: Range property query names

17131, “vasslitvinov”, “Range property query names”, “2021-02-09T08:05:22Z”

Here are some names or range methods that we consider changing


Is it better called isStridable() to indicate it is a boolean property?
OTOH stridable already sounds like it is a boolean.

If we do rename it, we can still have the range initializer or type constructor accept an argument called stridable. Although for a type constructor it seems like we’d have to have a (public?) field stridable to have like-named formal argument. At which point isStridable() would have to be in addition to stridable, which is undesirable.


The category of this method is less obvious. For example, is it a boolean property or a method that produces an “aligned” version of the range? Cf. there are also alignedLow and alignedHigh.

Proposed alternatives:
isUnambiguouslyAligned() // matches spec terminology, alas is a mouthful