New Issue: Let's rename the 'ChapelEnv' module - what should it be called?

18879, "bradcray", "Let's rename the 'ChapelEnv' module - what should it be called?", "2021-12-16T20:03:23Z"

The 'ChapelEnv' module is a bit clunky in name and contents. As part of the library stabilization
effort, we are discussing revamping both. Some of the reasons that we're not excited about
the current name include:

  • It implies it's talking about the environment for Chapel (the CHPL_* variables printed by
    printchplenv, say), but these settings can also be made through .config files, chpl
    command-line flags, or inferred. I.e., they're typically not obtained through the environment.
    And other things that are in the environment are not available.
  • We rarely type out 'Chapel' in full in code, and typically when we do for a module prefix, the
    implication is that it's an internal module (where Lydia correctly points out this module used
    to be internal; but that it didn't get renamed when it was promoted)
  • It's auto-used, so the name hasn't really mattered in user code (notably, its name doesn't show
    up in the standard module docs sidebar or index page either)

This issue is focused on what the name of this new module should be, where leading contenders include:

  • :+1: Configuration-based proposals: ChplConfig, ChplConfiguration
  • :heart: Compilation-based proposals: ChplCompiler, ChplCompilation, Compiler, or Compilation
  • :tada: both at once:: CompilerConfig, CompilerConfiguration
  • :rocket: Settings-based proposals: ChplSettings
  • :smile: Reflection-based proposals: ChplReflection, ChplQueries, CompilerReflection, Introspection
    • or, roll these capabilities into the existing Reflection module?
      • counterargument: Reflection seems to be more about code reasoning about itself than reflecting more generally on things that the compiler might happen to know; "Did the user throw --no-bounds-checks seems out-of-place
      • counter-counterargument: "code reasoning about itself"-Isn't that "SelfReflection", not "Reflection"?
  • :confused: Something else? (put your idea in the comments)

Add emoji to this OP with one or more of the families of names you prefer (and if you like a specific option or options from the family best, feel free to mention it in the comments below).

Options that were considered but not championed:

  • ~Chapel[mumble]~ : again, we don't typically spell Chapel out in code, these capabilities seem more to be reasoning about the chpl compiler than the Chapel language, see previous note about this typically being an "I'm an internal module" prefix
  • ~Settings / Configuration:~ felt too general-purpose and likely to be used by users to consider