[Chapel Merge] Deprecate bigint.powm in favor of bigint.powMod an

Branch: refs/heads/main
Revision: c1b9288
Author: lydia-duncan
Log Message:

Merge pull request #18139 from lydia-duncan/renamePowm

Deprecate bigint.powm in favor of bigint.powMod and document the latter
[reviewed by @bmcdonald3]

Resolves #17729

We decided to rename bigint.powm to bigint.powMod for clarity. Deprecate
the three overloads of powm in favor of new powMod overloads. While there,
add documentation for the powMod methods based on the GMP original
documentation for mpz_powm.

The GMP powers test needed an update to use the new method name. Copy the
original code into a new test to lock in the deprecation message.

Passed a full paratest with futures

Modified Files:
A test/deprecated/BigInteger/deprecatePowm.chpl

A test/deprecated/BigInteger/deprecatePowm.good
M modules/standard/BigInteger.chpl
M test/library/standard/GMP/ldelaney/gmp_Bigint_powers_roots.chpl

Compare: https://github.com/chapel-lang/chapel/compare/e90f6898852e...c1b92887ae9e