[chapel-lang/chapel] Don't set LIBFABRIC_DIR in the Shasta module.

Branch: refs/heads/release/1.22
Revision: ebba556
Author: gbtitus
Log Message:

Merge pull request #16258 from gbtitus/1.22-dont-set-LIBFABRIC_DIR-in-Shasta-module

Don’t set LIBFABRIC_DIR in the Shasta module.

(Duplicate PR #16210 from master to release/1.22.)

(Original PR reviewed by @ronawho.)

The system libfabric module for Shasta appears to have matured to the
point that we can depend on it to set PKG_CONFIG_PATH so that we can
always find libfabric. Therefore, stop setting LIBFABRIC_DIR, which we
were using to compensate for not having PKG_CONFIG_PATH.

As a side effect, this also solves a problem on some Shasta systems
where libfabric.so is in a …/lib64 directory but our util/chplenv
scripts were searching $LIBFABRIC_DIR/lib.

Modified Files:
M util/build_configs/cray-internal/generate-modulefile.bash

Compare: https://github.com/chapel-lang/chapel/compare/94ad2686174d...ebba55684d4c