New Issue: Unify argument names for assignment, binary, unary operators

18650, "bmcdonald3", "Unify argument names for assignment, binary, unary operators", "2021-10-28T22:35:39Z"

Currently, among the different data structures, there are various argument names for assignment, binary, and unary operators, but these would make sense to unify. Capturing some proposals that have been brought up in conversation below, please comment any additional proposals that you have in mind.

Proposed argument naming conventions

Type of operation positional minimal descriptive others
assignment (=) lhs/rhs x/y destination/source a/b, dst/src
op= assignment (e.g.,+=) lhs/rhs x/y lefHandSide/rightHandSide a/b. dst/src
binary (e.g, +) lop/rop x/y leftOperand/rightOperand a/b
unary (e.g., !) op x operand a

At some point, a straw poll would probably be the quickest way to settle these for the individual cases, but thought it would be worthwhile to collect all proposals first.