New Issue: Types module: renaming isCoercible?

18680, "mppf", "Types module: renaming isCoercible?", "2021-11-03T13:10:07Z"

Today, we have isCoercible available in the Types module:

However the terms "coerce" and "coercion" are jargon terms that are not used in the language specification (instead, the language specification uses the term "implicit conversion"). So, I think we should rename this method to use terminology consistent with the language specification.