19005, "lydia-duncan", "Math module - unifying argument names", "2022-01-14T16:54:02Z"
Argument name for a lot of the functions vary depending on the type of the argument - I see
i for integer,
x for real and
z for complex but not always. I think these argument names should be unified (probably to
There are two categories of functions that use a different strategy than the above. I think they should also be unified, but it seemed worth calling out how they are different in case they should stay as exceptions:
divceil, etc use
nfor their argument names. Should it be
yinstead? They at least seem to be consistent with each other.
modalso mostly uses the same names, but not always.
xfor the argument name except for the
log2variants which use
val. These should be unified (to
x, I believe)