New Issue: Math module - should we rename carg?

19006, "lydia-duncan", "Math module - should we rename carg?", "2022-01-14T17:14:24Z"

As someone who isn't familiar with this area of math, I have a hard time determining what this function is for based on its name. I believe C stands for complex in this case, but we've typically used it to refer to the C language in other parts of our code, so this overloads the abbreviation. The documentation says it computes the real phase angle of the argument - as a result, I propose renaming this function to phaseAngle, as it is more descriptive of its functionality.

We do inherit this name from C, so programmers familiar with it in that language may expect to use the same name. However, we can make it findable by using that name in our documentation.