New Issue: Math module - Rename Bessel functions

19051, "lydia-duncan", "Math module - Rename Bessel functions", "2022-01-19T19:35:51Z"

The names for these functions lack outside context and are very short - I propose renaming them in the following way:

old name new name
j0 firstBesselOrder0
j1 firstBesselOrder1
jn firstBesselOrderN
y0 secondBesselOrder0
y1 secondBesselOrder1
yn secondBesselOrderN

The documentation should use the old names, in case a user is searching for them based on that name.