New Issue: [Library Stabilization] Should the argument names for these BigInteger methods be longer?

17727, "lydia-duncan", "[Library Stabilization] Should the argument names for these BigInteger methods be longer?", "2021-05-13T18:57:28Z"

The arguments for divexact, divisible_p, divisible_2exp_p, congruent_p and congruent_2exp_p are a single character long. The letter used is descriptive (n for numerator, d for divisor and denominator, c for congruent, b for base), but it seems like having a longer argument name would be more friendly.

Do others agree?

If so, I'd like to propose:

  • bigint.divexact(numer, denom) (To avoid confusion with num for number)
  • bigint.divisible_p(div)
  • bigint.divisible_2exp_p(exp)
  • bigint.congruent_p(con, mod)
  • bigint.congruent_2exp_p(con, modExp)

You can find these function descriptions here: Integer Division (GNU MP 6.2.1)

(We talk about the names of the methods themselves in #17724 so I'm not going to have those changed here for clarity)