New Issue: Design: better naming/arrangement of 'dist' method and the 'dmapped' keyword

17908, "vasslitvinov", "Design: better naming/arrangement of 'dist' method and the 'dmapped' keyword", "2021-06-11T02:59:40Z"

Background: the domain keyword describes the generic domain type; it can also be used to query the domain value of an array expression.

This issue seeks elegant counterparts of these -- for the domain-map type and query.

Right now a domain-map value can be created:

  • implicitly in a dmapped clause of a domain type or value, or
  • explicitly with a new dmap(....)

The domain-map value can be queried using:

  • the dist method on domain expressions

Considerations about the dist method:

  • it is an abbreviation, while domain is spelled out; however, "distribution", when spelled out, looks too long, so we may not want that
  • it should refer to "domain maps"
    • whereas "distributions" are a subset of "domain maps" that refer to multi-locale domain maps, vs. "layouts" are domain maps that do not address multi-locality
    • we could also redefine a "layout" to be a special case of a "distribution" ("how are these indices distributed (stored) into this single memory?"), rather than a disjoint concept